Welcome, Guest. Please login or register.
Did you miss your activation email?
October 20, 2017, 11:20:25 pm

Pages: [1]
  Print  
Author Topic: Linux 64bit  (Read 21975 times)
Gnurfos
little robot
*
Posts: 2


« on: December 16, 2010, 10:35:23 pm »

Hi,

I am on a 64bit / Debian, and getting a bunch of these messages when starting the binary:


Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64

(Machinarium:21796): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(Machinarium:21796): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(Machinarium:21796): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(Machinarium:21796): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64


Followed by a segfault.
I have the ia32-libs and ia32-libs-gtk installed.
Is there more to it ? (I'm running low on disk space so trying to avoid blindly installing unneeded libs).

Or could you make a 64bit build of the game ?

Thanks.
Logged
Gnurfos
little robot
*
Posts: 2


« Reply #1 on: December 16, 2010, 11:18:49 pm »

I installed some additional ia32libs: curl3, idn11, and ssh2.
Now the warnings are still there, but the game runs !

A 64bit build would still be nice, though Smiley
Anyway, thanks for the Linux version !
Logged
ADie
little rusty robot

Posts: 1


« Reply #2 on: December 18, 2010, 10:33:56 am »

I installed the Download.tar.gz from Humble Bundle on openSuSE 11.2 64 bit and get a segementation fault without any more hints.

I feel confident that it's a problem of missing 32-bit-libs. Please give a list of "must-have" 32-bit libs.

But it would be much more better to have a native 64 bit binary

And PLEASE: Pack it into an installation package (rpm for openSuSE). Using package management would help to resolve dependencies. Installing binaries directly is Windows-like and crap.
Logged
charlieb
little robot
*
Posts: 2


« Reply #3 on: December 18, 2010, 02:09:50 pm »

ldd Machinarium will tell you exactly which libs are required and which are present or missing.

Code:
ldd Machinarium
        linux-gate.so.1 =>  (0xf77a0000)
        libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7698000)
        libpthread.so.0 => /usr/lib32/libpthread.so.0 (0xf767e000)
        libX11.so.6 => /usr/lib32/libX11.so.6 (0xf7564000)
        libXext.so.6 => /usr/lib32/libXext.so.6 (0xf7556000)
        libXt.so.6 => /usr/lib32/libXt.so.6 (0xf7504000)
        libfreetype.so.6 => /usr/lib32/libfreetype.so.6 (0xf747f000)
        libfontconfig.so.1 => /usr/lib32/libfontconfig.so.1 (0xf7451000)
        libgtk-x11-2.0.so.0 => /usr/lib32/libgtk-x11-2.0.so.0 (0xf708b000)
        libgdk-x11-2.0.so.0 => /usr/lib32/libgdk-x11-2.0.so.0 (0xf6ff5000)
        libatk-1.0.so.0 => /usr/lib32/libatk-1.0.so.0 (0xf6fd9000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib32/libgdk_pixbuf-2.0.so.0 (0xf6fbd000)
        libpangocairo-1.0.so.0 => /usr/lib32/libpangocairo-1.0.so.0 (0xf6fb2000)
        libpango-1.0.so.0 => /usr/lib32/libpango-1.0.so.0 (0xf6f71000)
        libcairo.so.2 => /usr/lib32/libcairo.so.2 (0xf6ed2000)
        libgobject-2.0.so.0 => /usr/lib32/libgobject-2.0.so.0 (0xf6e8c000)
        libgmodule-2.0.so.0 => /usr/lib32/libgmodule-2.0.so.0 (0xf6e89000)
        libdl.so.2 => /usr/lib32/libdl.so.2 (0xf6e85000)
        libglib-2.0.so.0 => /usr/lib32/libglib-2.0.so.0 (0xf6db5000)
        libnss3.so => /usr/lib32/libnss3.so (0xf6ca3000)
        libsmime3.so => /usr/lib32/libsmime3.so (0xf6c7e000)
        libssl3.so => /usr/lib32/libssl3.so (0xf6c50000)
        libplds4.so => /usr/lib32/libplds4.so (0xf6c4d000)
        libplc4.so => /usr/lib32/libplc4.so (0xf6c49000)
        libnspr4.so => /usr/lib32/libnspr4.so (0xf6c16000)
        libm.so.6 => /usr/lib32/libm.so.6 (0xf6bf1000)
        libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf6bd6000)
        libc.so.6 => /usr/lib32/libc.so.6 (0xf6a8a000)
        libXrender.so.1 => /usr/lib32/libXrender.so.1 (0xf6a82000)
        /lib/ld-linux.so.2 (0xf77a1000)
        libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf6a6a000)
        libSM.so.6 => /usr/lib32/libSM.so.6 (0xf6a63000)
        libICE.so.6 => /usr/lib32/libICE.so.6 (0xf6a4c000)
        libz.so.1 => /usr/lib32/libz.so.1 (0xf6a36000)
        libexpat.so.1 => /usr/lib32/libexpat.so.1 (0xf6a0d000)
        libXinerama.so.1 => /usr/lib32/libXinerama.so.1 (0xf6a0a000)
        libXi.so.6 => /usr/lib32/libXi.so.6 (0xf69fd000)
        libXrandr.so.2 => /usr/lib32/libXrandr.so.2 (0xf69f6000)
        libXcursor.so.1 => /usr/lib32/libXcursor.so.1 (0xf69ec000)
        libXcomposite.so.1 => /usr/lib32/libXcomposite.so.1 (0xf69e9000)
        libXdamage.so.1 => /usr/lib32/libXdamage.so.1 (0xf69e6000)
        libXfixes.so.3 => /usr/lib32/libXfixes.so.3 (0xf69e1000)
        libpixman-1.so.0 => /usr/lib32/libpixman-1.so.0 (0xf6975000)
        libpng14.so.14 => /usr/lib32/libpng14.so.14 (0xf694e000)
        libgio-2.0.so.0 => /usr/lib32/libgio-2.0.so.0 (0xf6863000)
        libpangoft2-1.0.so.0 => /usr/lib32/libpangoft2-1.0.so.0 (0xf683c000)
        libgthread-2.0.so.0 => /usr/lib32/libgthread-2.0.so.0 (0xf6838000)
        librt.so.1 => /usr/lib32/librt.so.1 (0xf682f000)
        libpcre.so.0 => /usr/lib32/libpcre.so.0 (0xf67f7000)
        libnssutil3.so => /usr/lib32/libnssutil3.so (0xf67df000)
        libXau.so.6 => /usr/lib32/libXau.so.6 (0xf67dc000)
        libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf67d7000)
        libuuid.so.1 => /usr/lib32/libuuid.so.1 (0xf67d2000)
        libresolv.so.2 => /usr/lib32/libresolv.so.2 (0xf67bd000)

I get the above and as you can see I have no missing libraries but I still get a segfault. Sad

Is it possible that the two libraries that are not specifically 32bit are the cause of this?

Cheers,
Charlie
Logged
charlieb
little robot
*
Posts: 2


« Reply #4 on: December 19, 2010, 03:23:29 am »

Right, curl. It's not listed in the linker dependencies but it is a requirement. Got it.
Logged
NomadDemon
little rusty robot

Posts: 1


« Reply #5 on: October 20, 2011, 12:32:26 pm »

bought game yesterday.

ubuntu 11.04 64 bit works great
only fullscreen have sluggish mouse movement when holding item.

thank you for linux games

[first game a bough in 10 years, just for linux support]
Logged
Nothor
little robot
*
Posts: 3


« Reply #6 on: January 04, 2014, 10:55:30 am »

Since in Ubuntu 13.10 64bits there is no more the "ia32libs" you need to follow the next steps:

There are 2 options to run Machinarium on Ubuntu 13.10 64bits.
Deb Package

If we have the .deb package (and yes! it is a 32bit package).

You must to install it with Ubuntu Software Center (not using dpkg -i), so simply double click the file.

To remove the game

sudo dpkg -r machinarium

TAR.GZ version

If you have the tar.gz version.

You need to install all those libraries.

sudo apt-get install libgtk2.0-0:i386 libnss3:i386 libcurl3-gnutls:i386 libidn11:i386 libpango1.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 librtmp0:i386 libxft2:i386

Run it on STEAM

In both cases if you want to run it with STEAM as a NO Steam game, you must to install also this last library.

sudo apt-get install libxtst6:i386

The original link here:
http://askubuntu.com/questions/356605/ubuntu-13-10-64-bit-machinarium-error-while-loading-shared-libraries-libgtk-x1/399355#399355
Logged
Pages: [1]
  Print  
 
Jump to: