Welcome, Guest. Please login or register.
September 18, 2018, 07:28:35 pm

Pages: [1]
  Print  
Author Topic: SOLVED: Machinarium does not work after Windows install  (Read 7825 times)
basso17
little robot
*
Posts: 4


« on: November 07, 2009, 03:51:20 am »

Hi,

I downloaded the Windows version and installed it from the .exe. The install seemed to go fine, but when i clicked on the desktop icon, I got only the notice about full screen and Esc, then just a black screen. What's more, not only did it freeze my mouse cursor, it froze my whole system. I couldn't even stop the game with Ctrl-Alt-Del and Task Manager.

Any ideas? Here's what I have:

ASUS Z84J laptop
Win XP Pro SP3/dual boot with Linux Mint 7
3 GB RAM
2 GHz dual-core Intel processor
NVidia GeForce Go 7700
80 GB partition on a dual-boot Linux Mint/XP machine
Outboard Seagate FreeAgent Pro 500 GB

I do have Avira Antivirus going and PCTools Firewall going. Could either be the problem? I was able to get it running on Linux with no difficulty, though I haven't gotten very far into the game.

Thanks for any input.
« Last Edit: November 09, 2009, 02:57:21 pm by basso17 » Logged
ABoretz
god of all robots
*********
Gender: Male
Posts: 666



WWW
« Reply #1 on: November 07, 2009, 04:43:55 am »


I don't mean to offend you, but I must ask, are you running a pirate copy or one that you downloaded from Amanita's server?

If it's the former you can check here to confirm that the checksums of the version you downloaded are correct.

If it's the latter I assure you that someone from Amanita will reply to your post within a day or two.

 Smiley

 
« Last Edit: November 07, 2009, 05:03:14 am by ABoretz » Logged
basso17
little robot
*
Posts: 4


« Reply #2 on: November 07, 2009, 05:57:07 am »


I don't mean to offend you, but I must ask, are you running a pirate copy or one that you downloaded from Amanita's server?

If it's the former you can check here to confirm that the checksums of the version you downloaded are correct.

If it's the latter I assure you that someone from Amanita will reply to your post within a day or two.

 Smiley

 

No offense taken. It's a legitimate copy that I paid $20 for and downloaded from Amanita's server.

I just went and checked the MD5 checksum of the file I downloaded, and it's correct.

FOLLOW-UP EDIT: I tried installing the game from the same burned disk on my older machine, a 2 GHz Athlon desktop with 2 GB RAM. Inexplicably (to me anyway), it installed perfectly on that one and seems to run fine. No idea why Machinarium doesn't like my dual-boot laptop, which is actually a more powerful machine.
« Last Edit: November 07, 2009, 11:33:06 pm by basso17 » Logged
basso17
little robot
*
Posts: 4


« Reply #3 on: November 07, 2009, 10:37:38 pm »

UPDATE: I uninstalled Avira Antivirus from my ASUS laptop and installed the free version of PCTools Antivirus instead. I ran a scan with PCTools and found that I had two infected files, neither of which seemed to have anything to do with Machinarium.

Anyway, the problem I was having is now gone! There was still an initial freeze-up when I clicked on the desktop icon to start the game, the same as there had been before, but this time it only lasted maybe 15 seconds, and then the game could be played and I had my cursor back.

I don't know if Avira was really the problem, but if anybody else encounters a similar issue, maybe this experience will help.
« Last Edit: November 07, 2009, 11:33:54 pm by basso17 » Logged
Pages: [1]
  Print  
 
Jump to: