Amanita Design forum

Machinarium => Machinarium iPad Version(s) => Topic started by: Zoozoo on July 12, 2015, 04:11:07 am

Title: REALLY frustrated with controls
Post by: Zoozoo on July 12, 2015, 04:11:07 am
I started Machinarium and I LOVE the art, the story, the puzzles... I find the in-game hints to be more than adequate to solve the puzzles. But the fine control is beyond frustrating. I have spent HOURS just getting levers to move, the robot to expand/contract, dials to turn the way I want them to. I'm ready to give up because it's just SO hard to control- it really fizzles the game when you know exactly what to do but can't control the motions. I play tons of fine-control Ipad games and have never had a problem, there's nothing else going on the pad... it's the game. It's just ridiculously hard to get it to do what I want.

Should I give up the Ipad and download it on my PC? Is that any better? I have had a lot of patience so far because of the quality of the story and puzzles, but I'm junking it if I can't find a better option for control.

Any suggestions?

Title: Re: REALLY frustrated with controls
Post by: Lamkin on July 12, 2015, 03:56:16 pm
This post might help with extending or shrinking the robot:

Others on the forum have mentioned some issues with performing certain actions on the iPad version, but most (if not all) issues have a solution, IIRC. Do you have any specific examples? Might be easier to help you then.

Title: Re: REALLY frustrated with controls
Post by: Zoozoo on July 13, 2015, 01:37:29 am
Thanks for answering!
It's not that I don't know how, it's that the game isn't very responsive. My Ipad is pretty new, and I'm not rough with it, and the pad is clean, so I don't think it's that.

Examples: moving the buttons on the machine that picks you up and drops you into the pipe at the beginning. SO hard to get the buttons to move. Giving things to people. I've tried over and over to give things to people when I KNOW it's the right thing to do, and it's just HARD. I've had to check walkthroughs to make sure I'm right, and spent a LOT of time hovering the object around the recipient until it takes. Moving the buttons on the star puzzle in the outside elevator (which is now stuck in a glitch, I think- the gray buttons are moving endlessly and nothing I do stops them). Honestly, the game is hard enough already without it being so hard to control things.

And IS the star puzzle thing a glitch? I've tapped every square millimeter of the screen to try to stop the jittering gray buttons, but it's just stuck. No walkthrough addresses this. I bobbled the pad and must have hit something weird and the buttons started moving by themselves, back and forth. ARGH, so frustrating.

Title: Re: REALLY frustrated with controls
Post by: Zoozoo on July 13, 2015, 02:12:13 am
I restarted and the solved the puzzle, and now it shows me a lever with two arrows, and I cannot move it correctly. I CANNOT figure out how to move it even with a walkthrough.
I'm all done with this game. It's a shame, because it's so beautiful and clever, but if an experienced gamer cannot make a lever move correctly, it's a BS game.

Thanks for the reply, but I'm trashing it. Too many problems with basic stuff.

Title: Re: REALLY frustrated with controls
Post by: Lamkin on July 14, 2015, 03:04:14 am
My guess is that you cannot move the lever because the elevator's motor isn't running. The lever moves the elevator up or down, but won't respond unless the motor is running. And the motor won't run until a) oil has been added to the tank, and b) the cord to start the motor has been pulled.