Amanita Design forum

Machinarium => Machinarium on Linux => Topic started by: nicolas on December 02, 2009, 07:05:21 pm

Title: Machinarium Linux FAQ
Post by: nicolas on December 02, 2009, 07:05:21 pm
Here is an attempt of answer to the most frequently issues encountered by Gnu/Linux users running Machinarium. :)

This is a work-in-progress. Let a reply if you have comments or ideas of answer to add.

Before purchasing, want to know in which format come the game package?
The game come in a simple tarball (tar.gz archive) that you can extract anywhere to play, whatever your distribution. Inside, there is a native Linux executable which launch a fullscreen Flash player with the game.

Is there any demo for Linux?
Yes, download it here: (

Using a 64-bits system?
Install a 32-bits compatibility package:
  • Debian/Ubuntu (and derivatives): install the ia32-libs package.
  • Fedora: there is no ia32-libs equivalent, but someone have made a list of all 32-bits compatibility packages (
    To install it, download this file ( and use these commands in the same folder (complete information there (
for i in $(< metztli-Fedora_agnostic-ia32-libs.text); do yum -y install $i; done
  • Gentoo: IA32 Emulation must be enabled in the kernel configuration
Executable file formats / Emulations --->
    [*] IA32 Emulation
    < >     IA32 a.out support
Then you need the same dependencies as 'www-plugins/adobe-flash' so you can just install that package (make sure you have the 'multilib' use flag enabled in case adobe releases a pure 64bit flash plugin again).
Note: you will need to accept the 'AdobeFlash-10.1' License in order to install that ebuild. Either add ACCEPT_LICENSE="AdobeFlash-10.1" to your make.conf or prepend it to your emerge command like that:
ACCEPT_LICENSE="AdobeFlash-10.1" emerge -av www-plugins/adobe-flash
    • Other distributions: see if you have an equivalent of ia32-libs, or install the equivalent packages of those mentioned in the Fedora list (you perhaps even can adapt the command in replacing 'do yum -y install' by the install command of your system).

    Lag when moving cursor (drag&drop objects, arrows cursor, legs cursor)?
    Deactivate hardware acceleration in the Flash settings panel (accessible through a right click on the game). If it's not sufficient try also to play in windowed mode and not in fullscreen.

    Other lags?
    See just above. ;)

    The Esc key doesn't quit fullscreen mode?
    Yes. The message at start is showed by Flash player, not by Machinarium itself, and seems to be wrong : you can't go windowed with the Esc key. Use the bottom in-game menu to stop fullscreen.

    Want to create a launcher for Machinarium?
    It avoids you to open your file manager and find the Machinarium folder each time you want to play. Just type this command in your launcher:
    bash -c "cd /-way-to-the-machinarium-folder/-name-of-the-machinarium-folder/ && ./Machinarium"
    Most of other commands doesn't works. You have to move your saves file (see below). More details in the topic "Create a launcher on Linux (,467.0.html)".

    I lost my saved games after using a launcher?
    When you used to launch the game directly through the executable, your saved games where there:
    With a launcher, the right folder is now at this place :
    ("strangething" is a serie of characters like ABCDE123, "localsomething" can be #localWithNet, localhost or localwithnet or perhaps others)
    So you have to move your Machinarium.sol file from the previous to the new place.

    Where are my savegames?
    See just above! ;) More information in the topic "Where are my Savegames (,463.0.html)" ?

    Blank black screen at launch?
    How do you launch the game ? Depending of the command, the game can not see its data. You have to launch it from its folder: directly or with a launcher (see "Want to create a launcher?" above).

    The sound is slightly delayed?
    Yes. :(

    Keyboard keys doesn't work in arcade games?
    This is a known issue. There isn't any solution now, so you will have to play with mouse at the moment.

    MOD edit by popsUlfr (06.08.10): added Gentoo 32bit compatibility hints to the 64-bit system subsection.

    Title: Re: Linux FAQ
    Post by: MikeCycloto on May 18, 2010, 11:17:23 am
    I had buy Machinarium when i was on a windows system.

    Can i freely download the setup for ubuntu now that i've change my O.S ?

    Title: Re: Linux FAQ
    Post by: nicolas on May 18, 2010, 12:13:45 pm
    If you've bought the game via the official Machinarium website, you just have to find the links that you've have received. One of them is for Linux. ;)
    If you've bought the game at another place (Steam, boxed version...), I don't know. You can perhaps try to contact Amanita.

    Title: Re: Machinarium Linux FAQ
    Post by: AlwaysLearning on December 22, 2010, 11:42:49 am
    Keyboard keys doesn't work in arcade games?
    This is a known issue. There isn't any solution now, so you will have to play with mouse at the moment.

    The space and arrow keys don't work in Windowed mode, but they work fine in Fullscreen mode.

    The Arcade is one of these areas where you'll find yourself switching between Windowed and Fullscreen mode a lot - provided you can actually access the menu at the bottom of the screen. To use the generator effectively you'll need to be in Windowed more (the mouse cursor lags too much in Fullscreen mode), then switch to Fullscreen mode to play each of the arcade games (because the keys don't work in Windowed mode).

    Good luck!

    Title: Re: Linux FAQ
    Post by: federer on May 07, 2011, 12:56:25 pm
    I had buy Machinarium when i was on a windows system.

    Can i freely download the setup for ubuntu now that i've change my O.S ?

    In these days this problem has been solved now, now you can easily download this setup for ubunto.

    Title: Re: Machinarium Linux FAQ
    Post by: Dorquemada on March 19, 2018, 12:38:26 pm
    I have the issue with the black screen. When the game starts, I see the Amanita logo, then the Machinarium logo appearing, after that I can access the menus on the bottom edge and also two (disabled?) icons in the top right corner, but everything else is just black.

    I got the game from GOG and used their Linux installer ( The game is installed in my home directory, all permissions and the launcher seem to be in order. I also tried to launch it manually, with same results.

    I ran it with strace, and I can see that the application successfully opens and reads files 00/00000000.000 and 00/11111100.111

    In the About box, I read that the hardware acceleration should be disabled, and tried to do this as well, but for some reason I can't. If I access the Flash settings dialog and uncheck the "Enable hardware acceleration", when I return to this dialog it is checked again. It works for the web plugin however, e.g. on Adobe's test page ( I can enable/disable acceleration and it stays that way.

    My specs:
    Gentoo Linux 64-bit

    EDIT: just figured it out - something was wrong either with the rights or some stale files/settings in the ~/.macromedia folder. After I deleted it, the game started properly