Welcome, Guest. Please login or register.
February 24, 2019, 01:11:02 am

Pages: 1 2 [3]
  Print  
Author Topic: Linux version?  (Read 62525 times)
popsUlfr
Global Moderator
black cap brotherhood boss
*****
Gender: Male
Posts: 270


Houndeye


« Reply #30 on: October 11, 2009, 03:01:21 pm »

Are you sure the ia32-libs are correctly installed? I just checked and this file is part of it.

Where did you check? It is definitively not in this package:
http://packages.debian.org/sid/amd64/ia32-libs/filelist

Nor is there a 32bit version of this file in any other Debian unstable amd64 package:
http://packages.debian.org/search?searchon=contents&keywords=libnss3.so&mode=filename&suite=unstable&arch=amd64

That's odd, I've checked the files the package installs through the terminal:
Code:
dpkg --listfiles ia32-libs | tee temp.txt
grep libnss3.so temp.txt
It would return me 2 entries saved in /usr/lib32
Quote
/usr/lib32/libnss3.so
/usr/lib32/libnss3.so.1d
Code:
rm temp.txt
to remove temp file.

Or
Code:
apt-get install apt-file
apt-file update
apt-file search libnss3.so
It gives a couple of matches with
Quote
ia32-libs: /usr/lib32/libnss3.so
ia32-libs: /usr/lib32/libnss3.so.1d

Edit:
I now copied the files libnss3.so, libnssutil3.so, libsmime3.so, libssl3.so from the i386 package of libnss3-1d and libnspr4.so, libplc4.so, libplds4.so from the i386 package of libnspr4-0d to /usr/lib32/.
This leads to another 64bit error:
(Machinarium-Demo:20336): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libglide.so: wrong ELF class: ELFCLASS64
But there *is* the 32bit version of this file available in /usr/lib32/... (from the package ia32-libs-gtk).

I wonder why my system does not try to use it.

You are starting it through the Terminal? try to launch the executable directly with a double-click on it.
Logged
Dude
little robot
*
Posts: 7


« Reply #31 on: October 11, 2009, 03:32:52 pm »

Quote
dpkg --listfiles ia32-libs | grep libnss3
No output for me.

Quote
apt-file search libnss3.so
Complete output:
Quote
iceape-browser: /usr/lib/iceape/libnss3.so
libnss3-1d: /usr/lib/libnss3.so
libnss3-1d: /usr/lib/libnss3.so.1d
libnss3-1d-dbg: /usr/lib/debug/usr/lib/libnss3.so.1d

You are starting it through the Terminal? try to launch the executable directly with a double-click on it.
That does not change anything. It doesn't happen anything.

I assume you aren't using plain Debian unstable?
« Last Edit: October 11, 2009, 03:34:34 pm by Dude » Logged
popsUlfr
Global Moderator
black cap brotherhood boss
*****
Gender: Male
Posts: 270


Houndeye


« Reply #32 on: October 11, 2009, 03:55:31 pm »

I assume you aren't using plain Debian unstable?

No, I'm not using Debian unstable.

Quote
dpkg --listfiles ia32-libs | grep libnss3

Oh! I've looked for a way to do just that without a temp file. Didn't think of piping it directly to the application.
Thanks!  Grin
« Last Edit: October 11, 2009, 03:59:07 pm by popsUlfr » Logged
Dude
little robot
*
Posts: 7


« Reply #33 on: October 11, 2009, 04:00:30 pm »

I assume you aren't using plain Debian unstable?

No, I'm not using Debian unstable.

Then what are you using?

Quote
dpkg --listfiles ia32-libs | grep libnss3

Oh! I've looked for a way to do just that without a temp file. Didn't think of piping it directly to the application.
Thanks!  Grin

No problem :-)
Logged
popsUlfr
Global Moderator
black cap brotherhood boss
*****
Gender: Male
Posts: 270


Houndeye


« Reply #34 on: October 11, 2009, 04:29:03 pm »

Then what are you using?

Forgive me, running on Linux Mint at the moment. It gets repositories from Ubuntu which in turn gets it from Debian.
Logged
robotics
little rusty robot

Posts: 1


« Reply #35 on: October 13, 2009, 07:53:14 pm »

Mě to taky nejdeeeeeeee! Debian Lenny 64 bit. Viz. f
Logged
amd64_user
little rusty robot

Posts: 1


« Reply #36 on: October 16, 2009, 03:44:44 pm »

How about an official Linux 64bit release? I am sure I am not the only one who would appreciate it.
Logged
Luca
little robot
*
Posts: 2


« Reply #37 on: October 16, 2009, 05:43:28 pm »

Please DON'T create port this game to Linux. I admin of StopLinux, and I think that linux is stupid system, but if Linuxoids want to play in games thay are free to use WINE. Linux do not needed native games. Look at it's drivers model! It's come from 1990 year! heh!
Logged
dirtyepic
little rusty robot

Posts: 1


« Reply #38 on: October 19, 2009, 08:44:29 am »

To play Machinarium on 64bit Gentoo Linux just emerge www-plugins/adobe-flash with the 32bit USE flag enabled.  This will install all the necessary 32bit libraries.
Logged
popsUlfr
Global Moderator
black cap brotherhood boss
*****
Gender: Male
Posts: 270


Houndeye


« Reply #39 on: October 19, 2009, 04:16:10 pm »

To play Machinarium on 64bit Gentoo Linux just emerge www-plugins/adobe-flash with the 32bit USE flag enabled.  This will install all the necessary 32bit libraries.

Thanks for the info, I will try it out. I had some trouble with the xorg-server, black screen. But gnome is working flawlessly... ok getting Off-Topic.

EDIT:Works like a charm Wink
« Last Edit: October 19, 2009, 05:22:37 pm by popsUlfr » Logged
nosense
little robot
*
Posts: 2


« Reply #40 on: November 21, 2009, 03:46:00 am »

Hi folks,

How about an official Linux 64bit release? I am sure I am not the only one who would appreciate it.

seconded (I'd like to run it on Debian 64-bit).

And would it be possible to make a statically linked version, perhaps?
I had to create symlinks on Debian (Etch) before I then ran into the glibc mismatch.

I bought it but I can't play it at all at the moment -- won't run in Wine, either. Sad
Logged
Pages: 1 2 [3]
  Print  
 
Jump to: