Welcome, Guest. Please login or register.
November 18, 2019, 10:52:17 am

Pages: [1]
  Print  
Author Topic: Crash on startup  (Read 17358 times)
stalker
little robot
*
Posts: 5


« on: August 05, 2011, 09:55:01 pm »

Hello! I am install the Machinarium on OS X 10.6.8 from Steam and if i lunch it the game crashing on startup. I am upgraded the flash player to the latest version, but it not help... (The mac os x is updated for the latest updates...)
This is the crash dump:

Code:
Process:         Flash Player [16686]
Path:            /Users/Stalker/Library/Application Support/Steam/SteamApps/common/machinarium/Machinarium.app/Contents/MacOS/Flash Player
Identifier:      com.macromedia.Flash Player.app
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [100]

Date/Time:       2011-08-05 23:37:23.995 +0400
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6

Interval Since Last Report:          304 sec
Crashes Since Last Report:           1
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      47C62B98-2FCB-48D9-9D31-DCBC0EFB8DD8

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  could not load inserted library: /Applications/Игры/Steam.app/Contents/MacOS/osx32/gameoverlayrenderer.dylib

Binary Images:
0x8fe00000 - 0x8fe4162b  dyld 132.1 (???) <1C06ECD9-A2D7-BB10-AF50-0F2B598A7DEC> /usr/lib/dyld

Model: MacBook7,1, BootROM MB71.0039.B0B, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.60f5
Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M, PCI, 256 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (5.10.131.42.4)
Bluetooth: Version 2.4.5f3, 2 service, 12 devices, 1 incoming serial ports
Network Service: BeeLine Internet, PPP (PPTP), ppp0
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: Hitachi HTS545025B9SA02, 232,89 GB
Serial ATA Device: OPTIARC DVD RW AD-5970H
USB Device: USB 2.0 Hub [MTT], 0x1a40  (TERMINUS TECHNOLOGY INC.), 0x0201, 0x26400000 / 2
USB Device: USB Gaming Mouse, 0x046d  (Logitech Inc.), 0xc041, 0x26440000 / 5
USB Device: USB Multimedia Keyboard, 0x046d  (Logitech Inc.), 0xc312, 0x26430000 / 4
USB Device: PTZ-630, 0x056a  (WACOM Co., Ltd.), 0x00b1, 0x26420000 / 3
USB Device: StoreJet Transcend, 0x174c  (ASMedia Technology Inc.), 0x5106, 0x24100000 / 3
USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8507, 0x24600000 / 2
USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06600000 / 3
USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8218, 0x06630000 / 5
USB Device: Apple Internal Keyboard / Trackpad, 0x05ac  (Apple Inc.), 0x0237, 0x06300000 / 2

Help me please!!! I don't now what to do...
Logged
Alex
Global Moderator
mayor robot
*****
Posts: 665



WWW
« Reply #1 on: August 05, 2011, 10:40:35 pm »


I searched GOOGLE for   Flash + "Exception Type: EXC_BREAKPOINT (SIGTRAP)"

And found this link: http://forums.adobe.com/thread/834979 (which may or may not help you)
"...caused by the 10.6.7 update breaking Java on OSX... managed to fix it by re-installing the 'Java For Max OS X 10.6 Update 4'"

If this works please write back to post your results.

Logged
stalker
little robot
*
Posts: 5


« Reply #2 on: August 06, 2011, 01:05:55 pm »

No... it not works Sad (I also try to disable hardware acceleration in flash player, but it not help me...)
Logged
Lamkin
Global Moderator

*****
Posts: leet



« Reply #3 on: August 06, 2011, 01:21:16 pm »

Does this thread (er, post) help?
http://forums.steampowered.com/forums/showthread.php?t=1818367
"Whenever I have my in-game overlay activated in prefs, only Valve titles will launch. All 3rd party titles get the same error. Seems 3rd parties dont like the steam overlay on my comp."
So, in Steam Preferences, under the IN-GAME tab, try unchecking the box that says "Enable Steam Community In-Game" and then try launching Machinarium again.
« Last Edit: August 06, 2011, 01:35:52 pm by Lamkin » Logged
stalker
little robot
*
Posts: 5


« Reply #4 on: August 06, 2011, 01:47:34 pm »

I try this, and have another crash (steamloader.dylib):

Code:
Process:         Flash Player [20216]
Path:            /Users/Stalker/Library/Application Support/Steam/SteamApps/common/machinarium/Machinarium.app/Contents/MacOS/Flash Player
Identifier:      com.macromedia.Flash Player.app
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [100]

Date/Time:       2011-08-06 15:45:59.284 +0400
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6

Interval Since Last Report:          18145 sec
Crashes Since Last Report:           6
Per-App Crashes Since Last Report:   6
Anonymous UUID:                      47C62B98-2FCB-48D9-9D31-DCBC0EFB8DD8

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  could not load inserted library: /Applications/Игры/Steam.app/Contents/MacOS/osx32/steamloader.dylib

Binary Images:
0x8fe00000 - 0x8fe4162b  dyld 132.1 (???) <1C06ECD9-A2D7-BB10-AF50-0F2B598A7DEC> /usr/lib/dyld

Model: MacBook7,1, BootROM MB71.0039.B0B, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.60f5
Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M, PCI, 256 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (5.10.131.42.4)
Bluetooth: Version 2.4.5f3, 2 service, 12 devices, 1 incoming serial ports
Network Service: BeeLine Internet, PPP (PPTP), ppp0
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: Hitachi HTS545025B9SA02, 232,89 GB
Serial ATA Device: OPTIARC DVD RW AD-5970H
USB Device: USB 2.0 Hub [MTT], 0x1a40  (TERMINUS TECHNOLOGY INC.), 0x0201, 0x26400000 / 2
USB Device: USB Multimedia Keyboard, 0x046d  (Logitech Inc.), 0xc312, 0x26430000 / 5
USB Device: USB Gaming Mouse, 0x046d  (Logitech Inc.), 0xc041, 0x26440000 / 4
USB Device: PTZ-630, 0x056a  (WACOM Co., Ltd.), 0x00b1, 0x26420000 / 3
USB Device: StoreJet Transcend, 0x174c  (ASMedia Technology Inc.), 0x5106, 0x24100000 / 3
USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8507, 0x24600000 / 2
USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06600000 / 3
USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8218, 0x06630000 / 5
USB Device: Apple Internal Keyboard / Trackpad, 0x05ac  (Apple Inc.), 0x0237, 0x06300000 / 2
Logged
Lamkin
Global Moderator

*****
Posts: leet



« Reply #5 on: August 06, 2011, 02:54:40 pm »

Have you tried deleting Machinarium from your Steam Library and then reinstalling it?
Logged
stalker
little robot
*
Posts: 5


« Reply #6 on: August 06, 2011, 10:51:32 pm »

Yes i tried this but nothing changed... the game is crushed on startup Sad
Logged
Lamkin
Global Moderator

*****
Posts: leet



« Reply #7 on: August 07, 2011, 01:00:12 am »

Not sure what to do other than to try and repair disk permissions with Disk Utility. Or maybe this page would be helpful:
https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335
Particularly this:
"Once you have verified the integrity of your game cache files, you can make sure that your extracted game files are correct by navigating to your Steam user directory: ..\Steam\steamapps\[USER NAME]\ and either renaming or deleting your game folder."

(And, for what it's worth, I also have a Mac running 10.6.8 and Machinarium plays on Steam for me without any problems.)
You might also try e-mailing Amanita Design to let them know about the problem. You can use the form at the bottom of this page:
http://amanita-design.net/about.html
Additionally, you might want to ask them if, while they look into the problem, they could send you a link for a standalone version.
« Last Edit: August 07, 2011, 01:30:15 am by Lamkin » Logged
stalker
little robot
*
Posts: 5


« Reply #8 on: August 08, 2011, 12:41:44 pm »

Thanks! Now all are worked! I try to reinstall steam client and after reinstall machinarium it work!
Logged
Pages: [1]
  Print  
 
Jump to: