Welcome, Guest. Please login or register.
July 25, 2024, 05:40:04 am

Pages: [1]
Author Topic: Running the game under Linux  (Read 68083 times)
Global Moderator
black cap brotherhood boss
Gender: Male
Posts: 270


« on: April 19, 2012, 11:31:34 pm »

I'll try to lay out the process of getting the game to run on as many distributions as possible.

1) Download the Linux version of the game from your Humble Bundle page and unzip the content (Botanicula.air)
Terminal way:
unzip botanicula-linux-*.zip

2) You'll need the Adobe AIR Runtime (much smaller since it doesn't come with the development files) OR Adobe AIR SDK installed minimum version being 2.6! Otherwise the game won't start.

Distro Dependant Procedures;

  • RPM (RedHat,Fedora,...) or Debian based Distributions (Ubuntu,Linux Mint,...):

Official Way:
-Download Adobe Air Runtime for Linux from here (at least version 2.6!)
-Either right click the AdobeAIRInstaller.bin, set its permissions to "Execute" and double-click it or the terminal way:
chmod +x AdobeAIRInstaller.bin

-Follow the installation procedures.

If you have issues intalling Adobe AIR, try this (thank you James Paige!):
I also had troubles with Adobe AIR, trying to install Botanicula linux box. Here are the problems, and how I worked around them:

(This is on an Ubuntu 12.04 laptop using the gnome-session-fallback window manager)

This installer: http://airdownload.adobe.com/air/lin/download/2.6/AdobeAIRInstaller.bin did not work for me. I could get it to run by setting the executable bit and running it from a terminal, but, it asked for my password, and when I typed it, the installer told me that I needed to install Gnome Keyring Manager (even though it is already installed.)

Then I found a .deb package for Adobe Air from here: http://update.devolo.com/linux/apt/pool/main/a/adobeair/ and it installed okay (dpkg actually printed out the same error about Gnome Keyring, but the install completed okay)

Then I ran the "Adobe AIR Application Installer" (which was in Applications->Accessories)

In the AIR installer I browsed to where I had unzipped Botanicula.air and selected it.

Then the Botanicula installer started up. it took a really long time, and maxed out my memory usage, and I was sure it had frozen up completely (the progress bar was pretty worthless) but eventually it did actually finish.

The Botanicula icon (named BotaAIRLinux) was installed in the wrong menu, Accessories instead of Games, so I moved it manually.

It works, and seems to run fine. I can play! I am excited about this game, and I am confident that the joy of playing the game will more than make up for the woefully crappy installer Wink
For 64bit:
dpkg -i adobeair_2.6.0.19170_amd64.deb
For 32bit:
dpkg -i adobeair_2.6.0.19170_i386.deb

  • Arch Linux:

-Install Adobe AIR from the AUR: adobe-air-sdk
Adobe Air Entry in the Arch Wiki

  • Gentoo:
-The Adobe AIR Ebuild is not available in the official Portage overlay but the xarthisius overlay has the version 2.6.
Either add the files to your local overlay or add it with layman

emerge -av layman
layman -L
layman -a xarthisius

Now if it's the first overlay you add, dont forget to update your PORTDIR_OVERLAY in your /etc/make.conf
source /var/lib/layman/make.conf

-You may now proceed with emerging dev-util/adobe-air-sdk-bin-2.6:
emerge -av =dev-util/adobe-air-sdk-bin-2.6

  • Sabayon:
-Sabayon is Gentoo based, and entropy doesn't provide the required 2.6 so the same steps apply.
Layman should already be present and configured, so all you need to do is add the overlay
layman -a xarthisius
and emerge
emerge -av =dev-util/adobe-air-sdk-bin-2.6

3) If the installer did everything correctly .air files should now be associated with the Adobe AIR. So all you need to do is execute/double-click your Botanicula.air you unpacked earlier.
You can also launch the game through the command line:

airstart Botanicula.air
« Last Edit: April 20, 2012, 12:36:57 am by popsUlfr » Logged
little robot
Posts: 4

« Reply #1 on: April 20, 2012, 05:15:05 pm »

air deb installer that could work for most ubuntu users:

citizen robot
Posts: 8

« Reply #2 on: April 20, 2012, 11:13:17 pm »

This is really helpful and clean:


This way, you don't need to install anything except maybe ia32-libs and friends,
just extract and run the game, the Air SDK ist just about 62 MB in size.

Thanks, DarkStarSword! Well found.
little robot
Posts: 2

« Reply #3 on: April 21, 2012, 12:53:23 am »

Thanks, DarkStarSword! Well found.
Glad I could help Smiley
Since this seems to be working for a few people I'm copying the solution here as well so it's easy for people to find:

Download the air 2.6 *SDK*, not the runtime (Adobe is clueless, their runtime is full of fail).
I assume that the SDK and Botanicula.air are in your current working directory. Run:

mkdir air Botanicula ~/BotaniculaSaves
tar xvjf AdobeAIRSDK.tbz2 -C air
unzip -d Botanicula Botanicula.air
echo 100,off,high,en,1,0 > ~/BotaniculaSaves/settings.txt

./air/bin/adl -nodebug Botanicula/META-INF/AIR/application.xml Botanicula/

That last line is all you need to start the game from then on, put it in a shell script or something.
little rusty robot

Posts: 1

« Reply #4 on: April 21, 2012, 12:45:48 pm »


its running in Fedora 16 (64bit) like a charm >>> report how-to (there i had to done some depencencies for adobeair...)

ps. thx for this good game, like for all games you have ever done (I like them all!)  Smiley

little robot
Posts: 5

« Reply #5 on: April 24, 2012, 06:12:49 am »

Linux Mint 10 is good to go.
Totally amazing so far. I've never seen anything like it. Cheers.  Cheesy
But not a good idea using Air, laugh.
little robot
Posts: 2

« Reply #6 on: May 01, 2012, 06:51:16 pm »

I have purchased and downloaded the game from Humble Bundle but it don't work. First the zip that download, either with bittorrent or direct download, is corrupted. Finally when I try to do what DarkStarSword post says it doesn't work, it throws the error: "application descriptor not found", normal if the zip is corrupted and the decompresed archive is not valid.

The version of the botanicula file corrupted is: "botanicula-linux-1.1-1335812481.zip". Somebody with the same error as me? Will you upload a fixed version?

Also, will you use non-adobe technologies in the future?



When I unzip:

$unzip botanicula-linux-1.1-1335812481.zip
Archive: botanicula-linux-1.1-1335812481.zip
inflating: Botanicula.air bad CRC ec24a2c2 (should be 4b227691)

When I try to execute the game:
$./air/bin/adl -nodebug Botanicula/META-INF/AIR/application.xml Botanicula/
[gtk warnings]
application descriptor not found

Note: my old machinarium bought directly to Amanita time ago works OK (outputs the same gtk warnings)

Now humble bundle has updated the zip and isn't corrupted anymore, but I still can't run the game. Still gave me the error "application descriptor not found" any ideas?

Debian SID amd64.

Now working thanks to SouseMouse script: http://forum.amanita-design.net/index.php?topic=3763.0.html Thanks SouseMouse and DarkStarSword!
« Last Edit: January 09, 2018, 04:45:17 am by Lamkin » Logged
little rusty robot

Posts: 1

« Reply #7 on: May 19, 2012, 03:20:45 pm »

Just adding info for arch linux users: there is a PKGBUILD supporting you with the botanicula installation in the AUR, see here: https://aur.archlinux.org/packages.php?ID=58649

playing right now, awesome work on all sides!

cheers, dpl
little rusty robot

Posts: 1

« Reply #8 on: July 12, 2012, 10:40:54 pm »

Hi, I guess I am one of those that have tried for hours and not succeeded...I managed to install the Adobe air Installation Installer (which was not easy), but I do not know what or where the Botanicula.air file should be I am supposed to open with that installer. I have downloaded the botanicula-20120501-i386.tar.gz file and extracted it - no such file! My system: Ubuntu 12.04 32 bit.
Somebody knows the answer?? Thanks!
PD: Needless to mention that all trials with the .deb files failed...
little robot
Posts: 4

« Reply #9 on: July 14, 2012, 09:50:49 am »

Hi, I guess I am one of those that have tried for hours and not succeeded...I managed to install the Adobe air Installation Installer (which was not easy), but I do not know what or where the Botanicula.air file should be I am supposed to open with that installer. I have downloaded the botanicula-20120501-i386.tar.gz file and extracted it - no such file!

If that's the same as the one I got through the Humble Indie Bundle, all I had to do was to unpack botanicula-20120501-i386.tar.gz and follow the instructions in the short README file, which basically boil down to "unpack the files where you want them, then run install.sh".

(The original release of Botanicula did require you to install Adobe AIR yourself, which was a bit of a hassle, but the updated version - which was released a week or two later, I think - shouldn't.)
Pages: [1]
Jump to: