Welcome, Guest. Please login or register.
September 24, 2020, 02:27:36 pm

Pages: [1]
  Print  
Author Topic: Blank black screen on linux  (Read 27704 times)
Linuxone
little robot
*
Gender: Male
Posts: 2


Linux User #375045


« on: October 26, 2009, 05:26:53 pm »

Hi all, Just bought the game, looks good from what I saw with the demo, looking forward to playing it.

I have one small (large) problem there though, When I start the game all I get is the instruction to hit ESC to get out of full screen mode (which does not work...erm ok so there are TWO problems I'm having) and then once that fades away all I get is a blank black screen and my mouse cursor, which I can move around but that's it.

Oh if I right click on the screen the flash player "settings" and "about" dialogue comes up and I can interact with them. And the flash player works perfectly for everything else that requires it.

My specs are as follows

PCLinuxOS 2009.2 fully updated
kernel 2.6.26.8.tex4
Flash player 10 3D Accel off
KDE 3.5.X
Dual core centrino CPU
2Gig Ram
512 Nvidia Vid Card, 3D accel on for normal use


Now I did notice one thing, When I purchased the game I saw that the linux version only works in 32bit. I took that to mean only 32bit OS,
but thinking about it now, I guess I should ask if it didnt mean 32bit "system" as in the hadrware and not just the OS.

Could someone help in shedding some light on this.
Logged

Cheers
Linuxone
popsUlfr
Global Moderator
black cap brotherhood boss
*****
Gender: Male
Posts: 270


Houndeye


« Reply #1 on: October 26, 2009, 05:37:36 pm »

Are you starting the game through a launcher or directly clicking on the "Machinarium" executable?
If it's the former check out this thread: http://machinarium.net/forum/index.php/topic,467.0.html

I can tell you that the game runs fine on 64bit Linux if you install for instance the "IA32-Libs" or you compile the adobe flash plugin with a "32bit" USE flag for Gentoo.
Here's the thread describing all this: http://machinarium.net/forum/index.php/topic,247.0.html (check page 2,3)
Logged
Linuxone
little robot
*
Gender: Male
Posts: 2


Linux User #375045


« Reply #2 on: October 27, 2009, 08:42:40 am »

Starting the game by just clicking on the executable.
Logged

Cheers
Linuxone
popsUlfr
Global Moderator
black cap brotherhood boss
*****
Gender: Male
Posts: 270


Houndeye


« Reply #3 on: October 27, 2009, 05:27:14 pm »

Starting the game by just clicking on the executable.

You are sure the "Machinarium" executable is in the same directory as the folders "00", "01", "10", "11"?

Open a Terminal and try to start the game by executing this line:
Quote
bash -c "cd {PathToMachinariumFolder} && ./Machinarium"
Where "{PathToMachinariumFolder}" has to be replaced by the actual path.
As seen here
Have a look at the output generated It may be useful.
Logged
sowa
little robot
*
Posts: 2


« Reply #4 on: November 08, 2009, 05:09:32 pm »

Please try to launch Machinarium from user account which owns executable. It Machinarium is for example owned by AnUser
Code:
ls -l Machinarium
-rwxr-xr-x 1 AnUser users 9696482 2009-10-11 04:23 Machinarium
then try to run Machinarium from AnUser account. I everything else fails, then use root account (usually not recommended).
Logged
thegreatpp
little rusty robot

Posts: 1


« Reply #5 on: November 17, 2009, 07:04:55 am »

I have the exact same issue as well; when I click the executable I simply get a blank screen, and the only thing I can do is bring up the flash player settings.  I am running Kubuntu 9.10, 32-bit, please help I can't find any other assistance on this issue.
Logged
nosense
little robot
*
Posts: 2


« Reply #6 on: November 23, 2009, 02:58:54 am »

I'd just like to add that I've got the same problem:

Debian Lenny (5.0.3, i386).

Procedure:

$ tar xvzf Machinarium_full_en_v2.tar.gz
$ cd Machinarium
$ ./Machinarium

It starts, goes fullscreen, I get the "Press Esc to exit full-screen mode" message, which fades away. And then it hangs. I can interact with the flash player's settings dialog through right-mouse click. I can switch back to other windows (I'm using blackbox as window manager). But the game hangs. I've tried disabling hw acceleration in the flash settings dialog, doesn't make any difference. This is rather disappointing.
Logged
tecknomage
little robot
*
Gender: Male
Posts: 5


WWW
« Reply #7 on: December 01, 2009, 04:58:23 pm »

Gees...

Why doesn't anyone give a fix.

I have the exact same problem as "nosense" & "thegreatpp"  Angry

Especially since I shelled-out $20 for this game, the publishers should have an obligation to provide the fix.

See my other post:  http://machinarium.net/forum/index.php/topic,733.0.html
« Last Edit: December 01, 2009, 05:01:00 pm by tecknomage » Logged

Tecknomage
Sandy Trunks
captain robot
****
Posts: 54



« Reply #8 on: December 01, 2009, 05:51:32 pm »

Gees...
Why doesn't anyone give a fix....


There are 7 people on the Amanita Design staff in total.
I think only 1 of them is the key programmer for the game.
There are at least 10 different distros of Linux out there.

Gees... Be patient or just DIY.   Tongue

Logged
xhajt03
little robot
*
Posts: 6


« Reply #9 on: February 14, 2010, 03:02:42 pm »

I'd just like to add that I've got the same problem:

Debian Lenny (5.0.3, i386).

Procedure:

$ tar xvzf Machinarium_full_en_v2.tar.gz
$ cd Machinarium
$ ./Machinarium

It starts, goes fullscreen, I get the "Press Esc to exit full-screen mode" message, which fades away. And then it hangs. I can interact with the flash player's settings dialog through right-mouse click. I can switch back to other windows (I'm using blackbox as window manager). But the game hangs. I've tried disabling hw acceleration in the flash settings dialog, doesn't make any difference. This is rather disappointing.


Check ownership and access rights of the 00, 01, 10 and 11 directories unpacked from the installation package and also access rights of the contents. I came across something similar as part of my issues and the simple reason was that files were owned by a user unknown on my machine and only that user had access to the files necessary for the game (mod 600)...

HTH

Tomas
Logged
df8oe
little robot
*
Posts: 3


« Reply #10 on: February 21, 2010, 03:13:04 pm »

I've got the same problem (Kubuntu 9.10), all permissions are correct.

So I build a small bash-script containing only these lines:

Code:
#!/bin/bash
cd /home/name_of_the_users_directory/Machinarium
./Machinarium

named it "start" and placed it in the Machinarium-folder (permissions to executable of course).

When I start clicking on the start - icon, it works perfectly.

Andreas
Logged
undrwater
little rusty robot

Posts: 1


« Reply #11 on: April 07, 2010, 06:30:10 am »

I'm on Gentoo and I had similar problems.  Permissions are definitely different than typical gentoo.  

Code:
chmod -R root Machinarium/
chgrp -R games Machinarium/

In the 00, 01, 10, 11 folders, the binaries have only root permissions, so I had to go into each and:
Code:
chmod 660 *

Now you can just start from cli, create a menu entry, or whatever.

Time to fix the slowness now.

Russell Dwiggins

PS: I put the game in the /usr/share/games folder, and made sure that the user is in the games group!
« Last Edit: April 07, 2010, 06:31:41 am by undrwater » Logged
Pages: [1]
  Print  
 
Jump to: