Welcome, Guest. Please login or register.
June 20, 2024, 09:18:22 pm

Pages: [1]
Author Topic: Doesn't start on Minix X8-H Plus [SOLVED]  (Read 13527 times)
little robot
Posts: 2

« on: July 25, 2015, 03:39:26 am »


I purchased this game from google play, but when I try to run it just quits immediately back to the desktop. I have a Minix X8-H Plus Android TV box. Runs Kitkat. Any ideas what is wrong? I thought maybe it didn't download properly so I uninstalled and reinstalled it. Same problem. X8-H Plus has 2GB RAM and a quad core processor so I don't think hardware is an issue.


« Last Edit: July 27, 2015, 06:37:53 am by Alex » Logged
Global Moderator
mayor robot
Posts: 665

« Reply #1 on: July 25, 2015, 07:08:45 pm »

I suggest you post your question on a Minix forum.

For example, I found this thread: http://www.minixforum.com/threads/problem-gaming-very-delayed-reaction-image-of-the-game.129/
"Good day. I Minix Neo-X8 H original firmware. I tried to play two games, Machinarium and Modern Combat 5. Minix reacts very slowly, especially in Modern Combat..."

So Machinarium WAS working on that person's Minix (albeit slowly?)  Perhaps you can register there, PM that user, and sort out what is causing your install to crash?  (there was mention of firmware updates in that thread, maybe that's your problem?)

In any case, good luck to you and please post a follow up when you find a solution.

« Last Edit: July 26, 2015, 10:37:57 pm by Alex » Logged
little robot
Posts: 2

« Reply #2 on: July 27, 2015, 02:28:55 am »

Well I powered it off last night and back on this morning, re-installed it, and it worked... Weird, who knows... least it's working...  Smiley

Great news!  Thanks for posting this follow up.
« Last Edit: July 27, 2015, 06:39:41 am by Alex » Logged
Pages: [1]
Jump to: