Welcome, Guest. Please login or register.
December 07, 2019, 03:51:13 am

Pages: [1] 2
  Print  
Author Topic: Manchinarium on Mini Laptop/ notebook  (Read 28107 times)
Ottis
citizen robot
**
Posts: 15


« on: March 31, 2010, 03:38:40 am »

I just got a new Acer Aspire One, Win XP Home, Intel Atom, 1GB ram 160gb HDD.

I think the problem is with the screen resolution, kind of odd, 1024x 600.
The game runs fine, as far as I've played it, but I can't access the menu at the bottom of the screen, and the only way I can end a game is to "ctl + alt + del" and End Task.

If I could get it out of Full Screen maybe it would show up, is there some way to change this without being able to get to the bottom of the screen??

BTW, love the game!!
Logged
Sandy Trunks
captain robot
****
Posts: 54



« Reply #1 on: March 31, 2010, 03:57:39 am »

I did a forum search for "Acer" and found this:  http://machinarium.net/forum/index.php/topic,952.msg4505.html#msg4505
Your solution has something to do with right clicking on the game's desktop icon and fiddling with the settings in order to play at 80% because you can't play at 100% on your specific netbook.  sorry to bear bad news.  Sad
Logged
Ottis
citizen robot
**
Posts: 15


« Reply #2 on: March 31, 2010, 05:16:10 am »

Hmmmm. Thanks for the reply, but none of the tips helped. I tried changing the screen res to 800 x 600 and running it, also tried running in different compatibility modes, no luck.
I'm going to try playing with the Windows registry settings, and see if it can be changed to 80% by an edit.
I've done registry editing  before, and don't recommend it for the novice, done wrong it can screw your PC up good.
I'll let you know if I find anything that works.    
« Last Edit: March 31, 2010, 05:18:20 am by Ottis » Logged
ABoretz
god of all robots
*********
Gender: Male
Posts: 666



WWW
« Reply #3 on: March 31, 2010, 05:34:05 am »


As you've already read, "You can view the game only in 100% mode (1250x790) or 80% mode (1000x632)".
But what happened when you tried: right-click on desktop icon > Compatibility > run at 640 X 480 resolution... Could you see the menu bar then?
Or howzabout you check out popsUlfr's "Display Changer" solution: http://machinarium.net/forum/index.php/topic,499.msg2432.html#msg2432?!

« Last Edit: March 31, 2010, 05:38:05 am by ABoretz » Logged
Ottis
citizen robot
**
Posts: 15


« Reply #4 on: March 31, 2010, 10:38:39 pm »

My screen only works at 1024x600, 0r 800x600, either way I can't see the bottom of the game screen. I tried the "Compatibility > run at 640 X 480", and tried running it with a screen res set at 800x600, the screen was still coped (@100%).

I haven't found the registry entry for display settings (80/ 100%) yet.   

Quote from: Display Changer
Warning
Normally, Display Changer will prevent you from using a mode that is not supported by your video card and monitor. You can use the -force switch to use an unlisted video mode. Please be aware that you can damage your video card or monitor by using an unsupported mode. 12noon assumes no responsibility or liability for your use of Display Changer.

The Acer Aspire One Video card (on board) only supports 1024x600 or 800x600, so I think I'll skip trying that.
No biggie, I can still play it on my desktop and my full size laptop, or just play it on my Acer without the use of the menu...

Still love the game!

Logged
jst65
space invader
*****
Posts: 142



« Reply #5 on: April 01, 2010, 12:13:48 am »

I can still play it on my desktop and my full size laptop
Then try this:
- on your desktop, start game, set it to 80% / Fullscreen Off, close the game
- on your netbook, rename the savegame/settings file "machinarium.sol" as "machinarium.sol.bak"
- copy machinarium.sol from your desktop to your notebook
- run game on netbook, should be windowed@80% now Smiley

To find machinarium.sol file see sticky post "Where are my savegames", http://machinarium.net/forum/index.php/topic,463.0.html.

I tried this on my PC, now I have a .sol file that starts a windowed@80% game and another one that starts it fullscreen@100%

Let us know!
Logged
Ottis
citizen robot
**
Posts: 15


« Reply #6 on: April 01, 2010, 09:47:54 pm »

I'll give it a try!
Logged
Ottis
citizen robot
**
Posts: 15


« Reply #7 on: April 03, 2010, 03:52:47 am »

Didn't work.
I saved at 80% on my full size laptop (Dell inspiron 6000, XP home) transferred the .sol file tomy Acer and opened the game. It took up where I had left off on my full size Dell, but still displayed at 100%.
I guess there's just something about the Acers display that wont let it work at 80%.
I also tried updating the video drivers without results.

I don't believe this is any kind of problem with the game, it's a hardware or driver  problem with the Acer laptop.

thanks for the help! Still love the game!!
Logged
jst65
space invader
*****
Posts: 142



« Reply #8 on: April 03, 2010, 02:19:25 pm »

Mumble. Have you set Full scren Off on Dell?
Logged
Ottis
citizen robot
**
Posts: 15


« Reply #9 on: April 03, 2010, 04:26:43 pm »

Mumble. Have you set Full scren Off on Dell?

If you mean set to 80%, yes.
I didn't see a way to reduce the window size. (?)
Logged
jst65
space invader
*****
Posts: 142



« Reply #10 on: April 03, 2010, 05:02:58 pm »

Mumble. Have you set Full scren Off on Dell?

If you mean set to 80%, yes.
I didn't see a way to reduce the window size. (?)
No I mean FULL SCREEN: ON/OFF
Its right near WINDOWS SIZE: 100%/80%
Logged
Ottis
citizen robot
**
Posts: 15


« Reply #11 on: April 03, 2010, 05:40:21 pm »

**Big loud forehead slap!**

AAARRRGGGgggggghhhhh.....

How did I miss that?Huh?.................... Roll Eyes
« Last Edit: April 03, 2010, 05:46:16 pm by Ottis » Logged
jst65
space invader
*****
Posts: 142



« Reply #12 on: April 03, 2010, 06:50:46 pm »

Smiley lol, well does it help?
Logged
Ottis
citizen robot
**
Posts: 15


« Reply #13 on: April 04, 2010, 02:14:26 pm »

I don't have my full size laptop with me right now, I'll get it back Monday.  I'll try it and let you know.
Logged
Ottis
citizen robot
**
Posts: 15


« Reply #14 on: April 10, 2010, 04:11:41 am »

Sorry for the delay, but I finally got to try the fix.
I still can't access the menu options at the bottom of the screen. I did save the game on my full size laptop with the full screen off and it opened on my acer the same way, with full screen off. However... The "scale" of the game doesn't change with the window size. Even with the taskbar moved to the side of the screen, moving the cursor around the bottom of the screen/ game window does nothing.
As I said, it seems that the scale of the game doesn't change with window size, so the options at the bottom of the screen are always "just out of reach".
The game still plays fine, and the top of the screen is normal so I can access my items and hints etc.

Mini laptops are becoming very popular, so this might be something to look into in future games or (dare I hope) a future Patch... Grin

Love the game! 
Logged
Pages: [1] 2
  Print  
 
Jump to: